Advertisements

MetaProperty is marked as secure error message in MSDeploy


So I was running this command on an IIS 6.0 box:

msdeploy verb:sync -source:webServer60 -dest:package=c:\package.zip

and kept getting this error:

Error: The property ‘value’ located at ‘/webServer60/metaKey[@path=’/LM/W3SVC’]/metaProperty’ is marked as secure. You must specify an encryption password to archive this property.

Since this was a production server setup by someone else, I thought that I had to get the password from them.  NOPE!!!  After an hour of scouring the web to see how even to set this password in IIS 6; a colleague pointed out that it needs the password to encrypt the metabase properties going into the package!!!!

So I could set any password!!! Just have to remember it when I go to deploy that package somewhere else.

Here’s to hoping you find this post before wasting an hour like me! 🙂

 

Advertisements

About Leonard Woody
Software Engineer

One Response to MetaProperty is marked as secure error message in MSDeploy

  1. Excellent post. I was checking continuously this blog and I am impressed!

    Very useful information specifically the last part 🙂 I care for such info a lot.
    I was looking for this certain info for a very long
    time. Thank you and best of luck.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: